Non-Latin characters appear as boxes in Windows 10

September 4, 2015
January 7, 2016

Non-Latin characters in the Imatest UI may appear as boxes in Windows 10, as shown.

Step 0

This is likely caused by not having the appropriate language pack(s) installed for your locale. You should not need to entirely switch the locale of your operating system.

The language resources mentioned in this post are provided by Microsoft and can be downloaded directly from your system’s control panel.

Before installing any language pack(s), exit Imatest. To install the desired language pack(s), access “Region & language settings” from the Windows 10 control panel. Alternatively, you can search for the terms “region language” in the start menu, as shown.

Step 1

From the Region & language settings window, select “Add a language”.

Step 2

Locate the language you wish to install. Repeat this step along with the previous for each language you wish to install.

Step 3

Windows 10 will download the necessary resources and automatically install the language pack

Step 4

At this point, the necessary language resources have been installed. Restarting your computer is recommended.

If, after restarting your computer, Imatest still is unable to display the desired language(s), return to the “Region & language” settings window. Select the desired language, and click “Options”. Depending on the language you wish to install, you may also need to Download additional resources, as shown.

Step 5

If you are still unable to view Imatest in your selected language, please contact support@imatest.com.

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*
Website