Documentation – Current v5.2

Imatest Image Acquisition with ApBase / DevWareX

Introduction

Imatest Master and Imatest IT support acquisition from On Semiconductor development boards, which are commonly accessed via On Semiconductor’s DevWareX tool. 

Connecting to a Device

To initialize a connection, open the Device Manager from the Data tab of the Imatest main window. Next, in the Device Manager, select the ‘On Semi DevWareX’ entry in the Device List. To attempt a connection, first supply the sensor data file (*.xsdat, *.sdat) by left-clicking the ‘Click here to add device files’ and then supplying your file. 

Once the sensor data file is supplied, the Device Manager will attempt to connect to the device. If the connection is successful, the Settings panel will populate with controls; otherwise, an error dialog will be displayed.

Loading Presets

To load a preset INI file, first navigate to the ‘Load Presets’ tab in the ‘Settings’ panel. To provide the INI file, either enter the full path or click the folder icon and select the file via the file selection dialog.

Once a preset INI file is supplied, the presets in the file will be displayed below in the ‘Load a Preset’ list. To load a preset, select the desired preset name and click ‘Load’. To mark a preset as the default, select it and click ‘Set as Default.’ The default selection will then be displayed in bold font.

Editing Register Values

The ‘Register View’ and ‘Register Access’ tabs in the Settings panel provide the information and controls needed to determine register addresses and to get or set an individual register. The ‘Register View’ tab lists register addresses, register descriptions and the data type descriptors for the values contained in the register. To access the register, provide the addresses and other info from the table to the corresponding controls in the ‘Register Access’ tab.

Acquisition

Within the Device Manager, once a connection is established and the preset INI file is loaded, you can start a preview by clicking the ‘Start preview’ button. 

Otherwise, to acquire from the interactive modules in Imatest, press the ‘Save’ button on the Device Manager before closing.