Documentation – Current v22.2

Imatest Instructions – Getting started

Current Documentation
View previous documentation
View legacy documentation
All documentation versions

Imatest software can measure a great many digital camera image quality factors from test chart images.

If you’re just getting started we recommend that you explore:

Image Quality factors page and IQ Testing for Beginners.

The two most popular charts types/analysis modules are SFRplus and eSFR ISO, These allow users to measure a great many image quality factors from single test chart images.  Other modules and charts let you meet a wide variety of testing challenges.

 

Links to Content on this page:

The Imatest workflowDownload & trialQuestionsInteractive vs. Fixed modules 
Selecting the chart and moduleRunning ImatestFinding Imatest HelpImatest main window 
Saved (INI) settingsWindow and font sizeOpen the image fileHelpful buttons
Raw filesMisc. controls and utilitiesEXIF displayROI Options – Options IIEXIF data settings
Dropdown menusTroubleshootingFigures – CSV & JSON output  – LicenseTips for successful testing

The Imatest workflow

Basic Imatest workflow
1. Determine the image quality factors (sharpness, color response, tonal response, noise, optical distortion, etc.) that need to be tested.
2. Select the test chart or charts needed to perform the tests. Charts are available in the Imatest store.
3. Photograph the charts, framing them according to the instructions for the intended analysis modules. If you’re starting out, sample images for several modules can be downloaded from Github.
4. Open Imatest and analyze the image using the appropriate module.
5. Interpret the results based on experience and by comparison with comparable cameras.
6. Save the results, which consist of figures and text (in CSV or JSON format), as needed.

 

Download & trial version — You can download Imatest here. Installation instructions are here. If you are a new user, a 14-day free trial will automatically begin when you run the software for the first time. When you are ready, you can purchase an Imatest license from the store and activate it as indicated in these links.

Online Activation | Offline Activation | Online Deactivation | Offline Deactivation | Floating Licenses | Proxy Server | The Knowledge base contains several links to help solve activation issues.
 
License Activation note:  Each Imatest license can be activated on only one computer at a time, but the activation can be easily moved between computers, especially if they’re online. You can install Imatest– and keep it installed– on as many computers as you like (Macintosh as well as Windows). To move the activation to another computer, you’ll need to deactivate it on the old computer then activate it on the new one, following the instructions above. You may do this as often as you like.

 

Most engineers use GUI-based Imatest Master.

Other versions of Imatest include: 

Imatest Studio, which has everything an individual photographer needs to test cameras and lenses (but lacks many of the advanced features for designing and manufacturing cameras), is available to individual photographers and small studios.

Imatest IT (Industrial Testing), is a non-GUI version of the Imatest software, designed for manufacturing environments. The IT interface will not be discussed on this page. 

 

 

Imatest Main Window

The Imatest Main Window allows the user to access all the features of Imatest.  Our Main Window was updated in the 2021.2 Release. Read about the new Imatest Main Window here

There is also an option to use the original Imatest interface, by choosing “Classic UI” in the Main menu – documentation on the classic Main Window is here.

Classic Imatest main wndow.
Click on image to view full-sized.

Interactive vs. Auto(Batch)

Most Imatest analyses can be performed in either interactive or Auto (Batch) mode. 

Full details can be found on FIxed vs. Interactive Modules.

In Version 2021.2, Imatest introduced a New Main Window – making it easier to select images and analysis. 

On the new Imatest Main Window (2021.2), choose the desired mode by setting the Interactive/Auto(Batch) switch option near the bottom of the Analysis card.

Interactive vs. Auto(Batch) Analysis options
(These should not be confused with automatic vs. manual region selection, described below in ROI Options.)

Interactive mode 

Use this mode to read and analyze images from files, or directly from acquisition devices and to interactively explore settings and results.

Auto (Batch) mode 

Use this mode to efficiently run analyses on individual files or batches of files, using settings that have been previously configured (prior to the auto/batch run).

In the new Imatest GUI, choose the analysis (such as eSFR ISO) and set mode on Analysis card to Interactive. In the new Imatest GUI, choose the analysis (such as eSFR ISO) and set mode to Auto (Batch)

If using the Classic Imatest UI window, this option is chosen by clicking on the Analysis in the Right column (Interactive).

Example: eSFR ISO Setup

If using the Classic Imatest UI window – this option can be chosen by clicking on the Analysis type in the Leftmost (Fixed) column.

Example: eSFR ISO Auto

Where both modes are available, Interactive mode should be run first to verify settings and results.
Auto(Batch) mode uses most settings that were configured during Interactive mode.
Parameters can be changed while analysis is run Parameters must be set before running in this mode.

Results can be examined in an interactive window.

Results can also be saved in CSV, JSON files, or HTML and PDF reports.

Results are in fixed Figures, CSV, and JSON files
Images to be analyzed can be obtained from image files or by direct acquisition, which is set up using the Device Manager.

Reads images from files only.

Batch read unavailable Can analyze batches of images by selecting multiple image files
Signal averaging is fast and convenient Supports signal averaging of multiple image files

Selecting the chart and module: What do you want to measure?

This guide is intended to help beginners select charts are most likely to meet their needs. Image Quality Factors and Sharpness contain extensive detail about the key measurements.

Skip this table if you’ve already selected your chart(s)

Guide to measurements, charts, and modules, indexed by measurement
Measurement Chart

New Main

Window

 Classic Interface

(Interactive modules shown in yellow.)

Sharpness (from any slanted-edge)
Manual ROI detection. Works with any slanted edge, including the old ISO 12233:2000 chart. ROI selection can be fussy when multiple images need to be analyzed.
Cropped slanted-edge image for measuring vertical MTF

In Analysis Options for “Sharpness”,  select Appropriate Target.

SFR

Rescharts

Sharpness,  Lateral chromatic aberration,  tones,  colors,  more…

These slanted-edge charts feature automatic ROI detection, and perform multiple image quality measurements. Can be run in either interactive mode (indicated by “Setup”) or fixed mode (indicated by “Auto”). They are compared here.

 

Each has specific strengths and applications.

SFRplus has the greatest spatial sharpness detail and good distortion measurements.

eSFR ISO performs detailed color and noise measurements and includes wedges for measuring aliasing and moiré.

SFRreg can be used for ultra-wide angle applications. Large SFRreg charts can be printed for long-distance measurements.

Checkerboard has the most accurate distortion measurements.

SFRplus, eSFR ISO, Checkerboard, and Dot pattern charts are designed to fill (or nearly fill) the image. Most other charts are designed to fill only a portion of the image.

In Analysis Options for

“Featured”, 

select SFR Plus target.

SFRplus Setup

SFRplus Auto

In Analysis Options for

“Featured”, 

select eSFR ISO target.

eSFR ISO Setup

eSFR ISO Auto

In Analysis Options for

“Featured”, 

select SFR Reg target.

SFRreg Setup

SFRreg Auto

In Analysis Options for

“Featured”,  select Checkerboard target.

Checkerboard Setup

Checkerboard Auto

Texture, Sharpness

Log Frequency-Contrast and Spilled Coins (or Random/Dead leaves charts). Important because slanted-edges cannot measure fine texture response.

In Analysis Options for

“Sharpness”,  select Log F Contrast target.

Log F-Contrast

Rescharts – Log F-C

In Analysis Options for

“Sharpness”,  select

Random/Dead Leaves target.

Random/Dead Leaves

Rescharts – Random

Sharpness,
Information capacity

The Siemens Star chart.

In Analysis Options for

“Sharpness”,  select

Star Chart target.

Star

Rescharts – Star

Sharpness,
Aliasing, moiré
Wedges are also a part of eSFR ISO.
Log F-contrast chart In Analysis Options for

“Sharpness”, 

select Wedge target.

Wedge

Rescharts – Wedge

Sharpness (relative)
from any image

Fast comparisons of batches of images
Measurements are non-standard.

Log F-contrast chart

Under Utilities Menu, Image Tools, choose

Find Sharpest Files

Find Sharpest Files

Color response,
Tonal response (OECF), noise,
Color Correction Matrix (CCM)

Color/Tone Interactive and Auto supports a great many grayscale step charts and color charts. Only a few are shown here.

ColorChecker SG
ColorGauge_120W ChromaDuMonde 28 test chart
In Analysis Options for

Color, 

select Appropriate target.

(Colorchecker 24, Colorchecker SG, 

General MxN Color,

and many other options)

Color/Tone Auto

Color/Tone Interactive

Dynamic range

Measured with multi-layer transmissive photographic film charts.
Learn more about Measuring Dynamic Range

dynamic_35_E_200W
Refer to Dynamic Range page.

Color/Tone Auto

Color/Tone Interactive

Stepchart (legacy module)

Color & tonal response
Colorcheck, which supports the X-Rite 24-patch Colorchecker-only.
Color/Tone is recommended for new work.

In Analysis Options for

Color, 

select “Colorchecker 24 via Colorcheck”  target.

Colorcheck
(legacy module) works only with the 24-patch X-Rite color checker.

Tonal response (OECF) & noise
Stepchart. Color/Tone is recommend for new work.

Image of the Q-13 Gray scale In Analysis Options for

Tone, select Appropriate target.

Stepchart
(legacy module) works with several grayscale step charts.

Uniformity of illumination,
Color shading, defect pixels

Versatile modules for analyzing flat-field images

Light Falloff contour plot In Analysis Options for

Uniformity,

select Uniformity target.

Uniformity

Uniformity Interactive

These modules work with flat-field images.

Blemishes (sensor defects)
Settings are carefully tuned so visible blemishes are detected and less-than-visible blemished are ignored.
Original test image (cropped) In Analysis Options for

Uniformity,

select Blemish target.

Blemish Detect

Works with flat-field images.

Distortion,
Lateral Chromatic Aberration

Compatible with several standards. Designed to fill (or nearly fill) the image.

In Analysis Options for

Distortion,

select Dot Pattern target.

Dot pattern

Distortion
Learn more about measuring Distortion

Checkerboard is more robust and accurate (and works with more distorted images) than the legacy Distortion module.

In Analysis Options for

Distortion,

select Checkerboard target.

Checkerboard Setup

Checkerboard Auto

Distortion  (legacy module)

Custom charts

Multiple image quality measurements

In Analysis Options for

“Featured”, 

select Arbitrary Charts target.

Arbitrary charts     Notes:

Imatest charts are available in several sizes and media:

    • Chrome on glass (up to 4×4 inches (100x100mm; ultra-fine; no grayscales)),
    • Color photographic film (up to 8×10 inches; fine; low noise),
    • Black & White film (up to 12×20 inches; noisier than color; good for NIR and SWIR (Near and Shortwave Infrared)),
    • Photographic paper (finer than inkjet and better for NIR and SWIR), and
    • Inkjet (up to 44 inches high; too coarse to be suitable for very small charts). You can print your own inkjet charts, but for highest quality we recommend purchasing them from the Imatest store.

We encourage customers to contact charts at imatest dot com with questions about chart suitability. Let us know your camera’s pixel resolution and field of view. 

Running Imatest

Imatest is opened by

  • double-clicking the Imatest icon Imatest_icon_16 on the Desktop,
  • from Windows Start menu: Start → All ProgramsImatest  → Version →   Imatest_icon_16 Imatest Edition , illustrated on the right.
  • or from the Imatest directory, typically C:\Program Files (x86)\Imatestversion (where version is Master, IS, Studio, etc.) in win64 English language installations.

After several seconds (up to a minute after the first installation or a reboot), the Imatest main window, shown below, opens.

In the New Imatest Main Window, user can select an image, and select the analysis to be run. (This can be done in either order.) Click the “Analyze” button to run. If ROI selection, or other settings are required, a window will pop up, for user entry. (If using the Classic UI, Imatest analysis modules are run by clicking on one of the buttons in the left two columns.)

Table of contents.

 

Finding Imatest Help

  • Comprehensive Imatest help can be found on the Documentation page (the Table of Contents)
  • The Help dropdown menu (top menu in the Imatest software) has links to important online documentation.
  • Tooltips (blocks of text that appear for a few seconds when you hover the mouse above a button) contain concise descriptions of the button function. 
  • In the Classic UI, right-clicking on most buttons in the Imatest main window (including the tabbed box on the right) opens a help document for the button function.  
  • VIDEOS and Online training are available.

 

If you’re starting out, sample images for several modules can be downloaded from Github.

Questions?  You can often find answers by searching the Documentation page or by searching the entire website using the magnifying glass icon on the upper-right of web pages. If that doesn’t work,

Send technical support questions to support at imatest dot com
Send sales questions (about purchases, renewals, etc.) to sales at imatest dot com.
Send test chart questions — especially about test chart customization — to charts at imatest dot com.

 

Each of these emails go to several people. It is helpful to include one of these, even if you are trying to reach a specific person, because you are more likely to get a quick response if that person is unavailable. Here are a few more helpful resources.

 

VIDEOS – Online training – Consulting 

Saved settings: imatest-v2.ini

Settings are saved in an INI file named imatest-v2.ini, described in detail in Saved settings (INI files) and in theManage settings button in the  Data tab .

Settings include Font size, folders for opening and saving images, calculation parameters, plot selection, and figures to display and save. Several INI file utilities can be accessed from the INI File dropdown menu, described below. You can view or edit the settings withINI file editor orView settings (ini file), save or load ini files, and do much more.

You can perform a number of functions related to troubleshooting and fixing errors, described in Saved settings (INI files), Troubleshooting, and the important Knowledge base post, A module that formerly worked has stopped working. The INI File Index, which will be of interest to advanced users, contains a description of the INI file monitor

Display dropdown menu

 

The Displaydropdown menu contains important settings that affect font, windows, and figure size. You should set fonts be the right size relative to the image: not too small, which makes test difficult to read and doesn’t utilized space reserved for text, and not too large, which causes text to cover other objects.

Display dropdown menu in the Classic Imatest UI : Font and window size settings
window_size_dropdown
Imatest main window with large (120 dpi) scale fonts

A really early version of Imatest

Imatest has several settings to adjust font and window size for the DPI scaling of different computers.

To access these, click Display (on the top bar of the main window), which opens the dropdown shown on the left. Settings:

  • Font size: set it so it appears correct in figures, i.e., not too small or large.
  • Normal or enlarged screen (Imatest main window).
  • Normal or enlarged figures (1.25 or 1.5x). You may need to enlarge the font for enlarged figures.
  • Normal or enlarged interactive windows (Color/Tone Interactive, Rescharts, Batchview, etc.)

 

Open the image file

Most Imatest analysis modules require an image file to be opened.

When you open the module (in some cases) or push a button to open an image file (in other cases), a dialog box opens that requests the name of the image file. Supported image file formats are summarized below.

Supported image file formats

See Image file formats and acquisition devices for full details. Summary:

  • Any file type supported by the Matlab imread statement. Rarely used formats grayed out.
BMP — Windows Bitmap JPEG (JPG) PNG — Portable Network Graphics
CUR — Cursor File JPEG 2000 (JP2, JPX) PPM — Portable Pixmap
GIF — Graphics Interchange Format PBM — Portable Bitmap RAS — Sun Raster
HDF4 — Hierarchical Data Format PCX — Windows Paintbrush TIFF (TIF) 8-48 bits
Multi-image TIFFs are supported.
ICO — Icon File PGM — Portable Graymap XWD — X Window Dump
  • Commercial raw formats converted using Libraw. These include CR2, NEF, RW2, and many more. See LibRaw 0.20 supported cameras. New cameras are typically added to LibRaw within a month or two of their introduction.
  • Binary files identified by extensions specified in the Generalized Read Raw window. You can set the pixel size,bit depth, demosaicing parameters, offset, etc., for the extension.
  • TGA (Targa)
  • Video formats, including DPX, Video DNG*, and ARI* (*converted using LibRaw)
  • CSV (a special format used in some infrared systems)
  • HDR  High dynamic range files
  • A large variety of image acquisition devices— too many to list here.

 

Multiple file read (batch mode)  You can select several files to read. Depending on how you respond to the multi-image dialog box (below),

The files should be in the same folder, have the same pixel dimensions (for most modules), and be framed identically (except for SFRplus and other modules that use automatic detection, where they can be any size). If you choose Combine files, you’ll have the option of saving the combined file with 16-bit TIFF format as default. Batch mode is not supported in interactive modules such as Rescharts or Color/Tone Interactive.

For combined files, the saved file name is the same as the first selected file name with _comb_n appended, where n is the number of combined files.

  • Enter additional input data. Unless Express mode has been selected, a Settings window opens that settings data, depending on the module. Most additional data is optional (and is saved from previous runs); you only need to pay attention to settings you wish to change. Click OK to run the program or Cancel to terminate the run.
  • Save results? After an analysis has been run, a dialog box asks if you would like to save the results. Checkboxes in the dialog box enable you to select the Figures, CSV (Excel-readable), and JSON files to be saved. You can examine the results before deciding which, if any, to save. (The Save box is omitted in the evaluation version.) Figures can be saved as PNG (losslessly-compressed) image files or Matlab Fig files (not recommended because of their large size. Fig files can be opened and manipulated with Open Fig file.

Helpful buttons

In the New Main window, click on the “Learn” Tab – to learn about Imatest Image Analysis, Charts, IQFs and Standards. It also has links to the Educational Apps. Or, click on Help menu on the top menu bar.

 

Buttons below are used to access help in the Classic UI.

Each of these buttons, which are in the tabs on the right of the image, opens a large Help window with lots of explanations and buttons that open a variety of functions. You should familiarize yourself with them and use them whenever the need arises.

Help guide (in the Help tab) opens a window with links to some of the most useful instruction web pages as well as brief explanations of what they contain, including Registration quickstart | Imatest instructions | Image quality factors | Imatest tour | Table of Contents (site map) | FAQ | Change Log | Testing lenses | MTF Curves & Appearance | SFRplus | Troubleshooting.

Manage settings (in the Data tab) opens a window that explains some of the key functions for setting and examining the contents of the file for saving Imatestsettings, imatest-v2.ini. It also displays the full path name to imatest.ini and shows how to fix bugs that can arise when imatest-v2.ini is corrupted. Function buttons include Save settings…, Load settings…, View/Edit settings (ini file), Copy settings (ini file), Import / Merge settings, Edit / Reset Modules, and Reset Defaults (all).

Error handling (in the Data tab) opens a window that shows what to do if you encounter an error. It includes link to the Change Log and Troubleshooting pages, buttons for Copying the current or last session to the clipboard for pasting into emails, and instructions on fixing imatest.ini when it gets corrupted.

Raw files

Raw files are the unprocessed output of digital image sensors. For Bayer sensors, each raw pixel represents a single color in RGRGRG, GBGBGB, … sequence. To be converted into usable, standard file formats (TIFF, JPEG, etc.), raw files must be processed by a raw converter. Raw converters perform several functions: demosaicing (converting the Bayer sequence into full color), applying a gamma curve, often with an additional tonal response curve, color correction and white balance, reducing noise, and sharpening the image. These operations affect Imatest measurements, especially sharpness (MTF or SFR).

The best way to be sure an image file faithfully resembles the raw file— that it has minimal processing— is to read a raw file into Imatest and convert it into a standard format (typically TIFF) using LibRaw for commercial raw files (identified by extension: CR2, NEF, etc.) or Generalized Read Raw for binary development files (also identified by extension, often RAW). For commercial raw files, the dialog box on the right appears. It allows you to choose among several raw conversion options. Details for both commercial and binary files can be found in Raw files.

Raw files can be converted with demosaicing (standard RGB format) or without demosaicing (which allows the original R, G(R), B, G(B) channels to be analyzed separately.

Exit closes all figures and terminates Imatest.

Close figures closes all figures. Important because the computer will slow down if too many are open. You can close figures individually by the usual Windows methods — clicking the X in the upper right or right-clicking on the figure icon on the Taskbar and selecting Close.

EXIF (in the Utility dropdown menu) displays EXIF metadata for an image file. Most file formats supported when ExifTool is installed (instructions below). EXIF data can be alphabetized to facilitate locating settings, copied to the clipboard (for pasting into a text editor), and saved in a text file in the same folder as the image file.

EXIF viewer

 

Options and Dropdown menus

We can only summarize the highlights of the Options windows and the dropdown menus because a full list of the settings and functions would be overwhelming (and difficult to keep up-to-date).

ROI Options and Options II… (in the Settings dropdown menu) opens the windows shown below, which allow several options to be specified.

ROI Options

Modules that offer automatic ROI selection (shown in the pink area below) also allow manual selection because automatic detection may fail on blurred, badly exposed, badly framed, or noisy images, as well as images with cluttered surroundings (neutral gray is always preferred).

Options I for setting ROI options and selection method (manual/auto)

Use new ROI selection method Opens a different window for selecting regions. It allows more flexibility in selecting multiple regions (SFR and Wedge), but frequently crashes. We recommend unchecking it for other modules.

ROI (Region of Interest) section controls cropping options.

  • SFR ROI filtering When Light filtering is checked the tests that validate the SFR ROI (region of interest) are relaxed. This can be useful when testing noisy images, rough edges, images of endoscopes or other devices with interfering patterns, but it can lead to errors if regions are selected carelessly. Normal filtering is the default.
  • Stepchart ROI selection Automatic patch detection (following manual region selection) can be toggled. If it is turned off, a fixed number of patches (6-41) can be selected for Stepchart analysis. This option is useful when high noise in dark regions confuses the automatic ROI detection.
  • Colorcheck, Distortion, Light Falloff Cropping options. You can select whether to ask for cropping and whether to use the last crop (for same-sized images). For Colorcheck you can also choose between traditional automatic patch detection and Color/Tone Interactive-like patch detection, where all squares are shown in the fine adjustment window.
  • ROI selection (Manual or Auto) can be selected for several modules. The  Auto ROI selection (global)  area lets you override the individual selections, as indicated. 
    Automatic ROI selection (detection) is supported by several test charts:  Colorchecker (in Colorcheck and Color/Tone), Random (Spilled Coins, Dead Leaves), 36 patch Dynamic Range, Contrast Resolution, ISO 14524*, ISO 15739*, Log F-Contrast*, Siemens Star*, and Rezchecker (versions with dots in four corners).  *recent versions of these charts with registration marks in the corners.
    New in 2021.2:  The Matlab Colorchecker auto-ROI method (9 and 10) has been added to the many options available for the Colorchecker chart.

Colorchecker ROI selection options: 2,3,9, and 10 are for auto detection. 9 and 10 are new in 2021.2

Reset restores defaults: it sets SFR ROI filtering to Normal, Stepchart ROI selection to Automatic.

Options II

Options II for setting numerous options

Global folders The default folders for opening files and saving results can be set globally using the second group of controls. Normally (with Global folder for opening files unchecked), the default folder for opening files is changed only for the Imatest module in use: one module at a time. When it is checked, the default folder for opening files is changed for all modules. This can be convenient if project data for several modules is stored in the same file.

When Global folder for saving results is checked, the default save folder is changed for all modules whenever the input folders are changed.

 

EXIF data acquisition settings This selects the program used to read EXIF data: image file metadata that contains camera and lens settings. Selected EXIF data (important values such as aperture, exposure time, ISO speed, and focal length) is displayed in several figures and EXIF data is saved in CSV and JSON output files. There are four settings:

1 Do not get EXIF data (for rare cases of errors) EXIF off
2 Get EXIF data from Phil harvey’s ExifTool (all file types; must download & install) Recommended
3 Get EXIF data from ExifTool & save ALL EXIF data in csv output (LOTS)! Detailed!
4 Get EXIF data from Matlab’s built-in function (limited) Limited results

Recommended settings 2 and 3 (ExifTool) work with virtually any file type and capture virtually all available EXIF data. If the setting 3 (save ALL EXIF) is selected, all the EXIF data— a large amount; some quite obscure— is written to the CSV output files. Setting 4 (Matlab’s built-in function) returns limited results. Setting 1 is for rare cases that cause EXIF read to crash (it’s also faster).

The second and third settings require ExifTool, which is included in Imatest installations, but is frequently updated. If you need a newer version,

  • Go to the ExifTool home page and download the Windows standalone executable (a zip file).
  • In Windows Explorer, double-click on the downloaded zip file.
  • Copy the contents ( exiftool(-k).exe ) to the appropriate installation folder. To find the location in Imatest 5.0+, click Open utilities folder to the right of EXIF data acquisition. In older versions you will need to search for exiftool in C:\Program Files\Imatest\ or C:\ProgramData\Imatest\ (including subfolders). [In my (English-language) computer the location for Imatest Master 4.2 is C:\Program Files\Imatest\v4.2\Master\imatestis_mcr\depends\RTDepends. The location for Imatest  Master 5.0 is C:\ProgramData\Imatest\mcr_cache\5.0\Master\mcrCache9.2\imates0\depends\RTDepends.]
  • Rename exiftool(-k).exe to exiftool.exe.

EXIF color space settings can be confusing because two tags affect color space, and their relationship is not logical.

Color space (where you would logically expect to find the color space) can contain either sRGB (the Windows/Internet standard) or Uncalibrated (1 or 65535). If Color space is Uncalibrated, the color space is located in the Profile Description tag, which can be interpreted as Adobe RGB, Display P3, etc. (Did I say not quite logical?) See www.exiv2.org/tags.html


YUV format  Imatest
supports several flavors of YUV file, which can be selected. Details here.

DNG (Adobe Digital Negative) file reading  lets you select how DNG files are processed. Details here

Suffix for saved SFR plots and CSV and JSON files Normally the root name (input or selected file name ) is followed by the channel, ROI orientation (AL = above left (relative to the center), etc.) and distance from the center in percentage of distance to the corner. Example: rootname_YAL79_MTF.png for the Edge/MTF plot. An alternative can be selected where _ROI_ followed by the ROI number nn is used in place of the orientation and distance. Example: rootname_ROI_03_MTF.png

Special user code enables custom features for specific users. Normally blank.

Reset restores defaults: it sets SFR ROI filtering to Normal, Stepchart ROI selection to Automatic, turns off all global folder settings, and checks Get EXIF data .

Help opens a relevant web page on computers connected to the Internet.

The Options III window (not shown) contains some obscure settings (with explanation text) that most users won’t want to change. The Luminance Calculation lets you choose between the Rec. 709 luminance (Y) calculation:  Y = 0.2125*R + 0.7154*G + 0.0721*B (default; newer) and the older calculation:  Y = 0.3*R + 0.5G*G + 0.11*B (older; not recommended).

Figures

 

Imatest figure: You can resize it or zoom in on individual plots.
The toolbar, which includes Data cursor Data Cursor icon, is shown.

Imatest results are displayed in individual windows called Figures. A typical figure— a result of running SFR— is shown on the right.

Figures may be resized, minimized, maximized, or closed using standard Windows operations. In addition, several Windows and Matlab-specific operations can be found in the toolbar at the top of the image.

The first four icons in the toolbar are standard Windows icons: New file, Open, Save, and Print. Open and Save refer to Matlab .fig figures, which should be used sparingly because they require excessive storage. 

Of the remaining icons, Zoom in: is particularly useful. Clicking on it highlights it and enables you to zoom in on regions of the plots. You can click and drag to create a zoom rectangle or you can click on any point to zoom in on that point. Double-clicking anywhere inside the image restores the full unzoomed image.

Data Cursor example

Data cursor example

Data Cursor, selected on by the Data Cursor icon toolbar icon, lets you click on a curve and display its coordinates in a small box called a Datatip. Right-clicking on the Datatip lets you can delete it or choose additional options.

In most modules, figures can be saved as either PNG files (a standard losslessly-compressed image file format) or as Matlab FIG files, which can be opened by Open Fig file in the Utility dropdown menu, then manipulated (zoomed and rotated). PNG files are usually preferred because FIG files require much more storage, especially for 3D FIG files, which can be rotated. 

Too many open Figures

Figures can proliferate if you do a number of runs, especially runs with multiple regions. System performance degrades if too many Figures are open. Figures can be closed individually by clicking X on the upper right of the Figure or by any of the usual Windows techniques. You can close them all by clicking Close figures in the Imatest main window.

CSV and JSON output files

Individual Imatest modules can optionally write two types of output file that contain most results.

  • CSV files are most often displayed with Microsoft Excel.
  • JSON files, which contain a single large JSON structure, can be read into programs written in almost any language with a single line of code using functions linked from the JSON website. They can be displayed in any text editor.

Please contact us if you have requests or suggestions about Imatest output. [Notes: These files are not saved in evaluation mode. ]

CSV files Excel-readable Comma-Separated Variable format. Here is an example of typical output.

Module,Colorcheck
File,Canon_EOS10d_ColorCheck_lt_small.jpg
Run date,31-Dec-2005 18:11:00
Zone,Gray,Pixel,Pixel/255,Px/255 ideal,Log(exp),Log(px/255),WB Err Deg,WB Err Mired
19, 1, 241.6, 0.9475, 0.9569, -0.050, -0.023, 163, -3.8
20, 2, 215.8, 0.8464, 0.7922, -0.230, -0.072, 491, -10.8
21, 3, 179.0, 0.7020, 0.6353, -0.440, -0.154, 450, -10.0

The same data displayed in Excel looks like this.

Sample .CSV output displayed in Excel

JSON files are somewhat human-readable text files that contain a single structure— optimized for reading into programs written in virtually any programming language.

{
      "jstruct": {
            "dateRun": "03-May-2018 12:14:03",
            "ini_time_size": "03-May-2018 12:02:35 104121B  MD5 = 6a03a447754eefcc2ada6698ec63d30e",
            "version": "Imatest 5.1.0. ALPHA  Colorcheck",
            "build": "NOT COMPILED",
            "full_path_name": "C:\\imatest\\Data\\Colorcheck\\Canon_eos10d_ColorCheck_lt.jpg",
            "file_name": "Canon_eos10d_ColorCheck_lt.jpg",
            "mean_cameraSat_Pct": [0.9888],
            "pxlLevel_graypatch": [241.67,215.9,179.27,135.26,84.58,34.63],
            "pxlLevel_norml_graypatch": [0.9477,0.8467,0.703,0.5304,0.3317,0.1358],
            "densityNominal": [0.949,0.7882,0.6314,0.4784,0.3255,0.1922],
            "logExposure": [-0.05,-0.23,-0.44,-0.7,-1.05,-1.5],
            "logNormlPxlLevel": [-0.023,-0.072,-0.153,-0.275,-0.479,-0.867],
            "whiteBalErrDegs": [157.3,478,487.1,833.4,954.2,568.3],
...
            "Mean_Delta_E_00": [5.31],
            "Max_Delta_E_00": [11.42],
            "Sigma_Delta_E_00": [5.76],
            "Mean_Delta_C_00": [3.05],
            "Mean_White_Balance_delta_C_00": [2.87],
            "Max_Delta_C_00": [7.52],
            "Sigma_Delta_C_00": [3.45],
            "Mean_Delta_C_00_Sat_corrected": [3.08],
            "Max_Delta_C_00_Sat_corrected": [7.5],
            "Sigma_Delta_C_00_Sat_corrected": [3.44],
            "passfail": {
                  "ini_time_size": "04-Jul-2017 09:31:58 1734B  MD5 = 1a759325ea50ce2c4bc826dae419feac",
                  "passFailFile": "C:\\imatest\\Data\\ini_files\\passfailtest_1.txt",
                  "started_at": "2018-05-03 12:14:03",
                  "ended_at": "2018-05-03 12:14:20",
                  "runtime": [9.135914449],
                  "INI_read_success": "[colorcheck] NOT FOUND",
                  "all_tests_passed": [1]
            }
      }
}

 

Imatest license (EULA)

The full text of the Imatest license can be found here.

License holders are encouraged to publish test results in printed publications, websites, and discussion forums, provided they include links to www.imatest.com. The use of the Imatest Logo is encouraged. However you may not use Imatest for advertising or product promotion without explicit permission from Imatest LLC. Contact us if you have questions. 

Tips for successful testing

Imatest LLC assumes no legal liability for the contents of published reviews. If you plan to publish test results, especially for MTF, you should take care to use good technique. Considerations include,

Sturdy camera support Use a sturdy tripod, cable release, and, if possible, mirror-lock on DSLRs. Imatest offers high quality solutions for professional test labs.
Target mounting If you are working outdoors, be sure the target doesn’t shake in the wind.
Target distance Be sure you’re far enough from the target (the magnification is low enough) so the printed edge quality doesn’t affect the measurements. Target distance considerations are given here.
Focus Be sure the camera is focused accurately on the target. Note whether you used manual or automatic focus. Some targets, like Spilled Coins/Dead Leaves targets, may work poorly with autofocus.
Target alignment In most cases, the chart should be normal (perpendicular) to the optical axis of the lens. Make sure the corners, as well as the center, are in focus.
Illumination Should be as even as possible. Use an incident light meter if needed.
Exposure Take care not to clip (saturate) shadows or highlights. This will reduce accuracy of the results.
Raw conversion and settings The Raw converter (in or out of the camera) and image processing pipeline, particularly Sharpening, can make a huge difference. Contrast and White balance are also important. Settings that affect contrast and transfer curve can also have a strong effect. If possible a “Linear” setting (meaning a straight gamma curve with no additional tonal response adjustments) should be used.
Gamma SFR sharpness results are moderately sensitive to the Gamma setting: A 10% gamma error changes MTF50 by 2.5%. Gamma can be measured from slanted edges of known contrast (if ≤ 10) or from a grayscale chart by running Color/Tone Interactive, Color/Tone Auto, Colorcheck or Stepchart.
Cleanliness and filters Lens surfaces should be clean. You should note whether you have a protective (UV or Skylight) filter. It can make a difference— more likely reduced contrast than reduced sharpness. With Imatest you can find out.
File formats Use Raw, PNG, TIFF, or the highest JPEG quality. Never use less than the maximum resolution or JPEG quality unless you are specifically testing the effects of these settings.
Lens settings Lens performance is a strong function of the aperture (f-stop) and focal length (for zooms). Be sure to record these settings (easy because they’re saved with the EXIF data) and include them in your reports. The optimum (sharpest) aperture is of particular interest. Lens performance is also somewhat affected by the distance to the target. Rename Files can add key settings to the image file name using EXIF data.
White balance Should be close as possible to neutral, particularly in Colorcheck.
This may seem like a lot of fuss, but the technique you develop in testing cameras and lenses will spill over to your daily photography. Alfred Stieglitz tested film and developers extensively when he discovered photography as a student in Berlin. Ansel Adams performed extensive tests in the development of his zone system. Although nobody would claim that testing is responsible for their unique vision, it certainly contributed to the skill that transformed their vision into prints of transcendent beauty.